
 

 

 

User Guide: AI InstrumentTM Plugin 
 

Have feedback or found a bug? Let us know at contact@staccato.ai. 
If your bug report is confirmed, you’ll receive one month of the plugin free. 

 
QUICK START: See Section 6. Prompting, for example prompts you can use with Staccato. 
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1. Introduction 
Welcome to the AI InstrumentTM, the MIDI co-writer designed to support music producers and 
composers with originality, creativity, and precision. 

Beat writer’s block and enhance your composition process like never before. Simply enter text 
prompts or let the AI InstrumentTM listen to your existing MIDI to create original stems, extend 
your ideas, or modify parts, all ready to drag into your DAW. 

 

 

2. System Requirements 
● macOS 10.15 or later / Windows 10 or later 

● 4GB RAM (8GB recommended) 

● 50mb of hard drive space 

● Internet connection required for AI prompt processing 

● Standalone (recommended), VST3, or AU host 

 

3. Installation 
3.1 Standalone Installation (Recommended) 
 

We recommend using the standalone version for the best performance and simplest setup. It's 
easier to manage overall, since you don’t have to keep track of which project tracks the AI 
Instrument™ is loaded on. And because it supports multitrack use, it’s more flexible when it isn’t 
tied to a specific track. 

Steps: 

1. Visit the Staccato AI Instrument™ download page. 

2. Choose the installer for your operating system 

3. Run the installer and follow the prompts 

4. On Mac: 
a. Click the Finder icon in the bottom-left corner of your screen (in the Dock) 

https://staccato.ai/plugin


 

 

    
b. Click the magnifying glass in the top right corner 

 
c. Type “Staccato AI Instrument” into the search bar 

 

d. Double-click “Staccato AI Instrument” to open 

 

5. On Windows: 
a. Click the Start menu (Windows icon in the bottom-left corner of your screen) 

  
b. Type “Staccato AI Instrument” into the search bar 

  
c. Click “Staccato AI Instrument” in the search results to open 

  

 

 

 

3.2 VST3 / AU Plugin Installation 
If you prefer using the AI InstrumentTM as a plugin: 

1. Visit the Staccato AI Instrument™ download page. 

2. Choose the installer for your operating system 

3. Run the installer and choose your plugin folder 

● If left unchanged, VST3/AU files will automatically install into your default plugin 
directory: 

https://staccato.ai/plugin


 

 

1. Windows: C:/Program Files/Common Files/VST3 

2. MacOS: /Library/Audio/Plug-Ins/Components 

4. Restart your DAW and scan for new plugins 

5. Load the AI InstrumentTM on a MIDI track 

6. See Section 3.3 for installation instructions specific to each DAW 
 

3.3 Opening the AI InstrumentTM in Your DAW 
 

Ableton Live 

Watch the Ableton Setup Tutorial on YouTube 

1. Open Options > Preferences > Plug-Ins 

2. In “Plug-in Sources” set “Use VST3 Plug-In System Folders to ON 

3. Enable "Use VST3 Plug-In System Folders" and click “Rescan Plug-Ins” 

4. Close Options, select your desired track, and in the browser, open Plug-Ins > VST3 (or AU) 
> Staccato > AI InstrumentTM 

5. Load the AI InstrumentTM into the MIDI track or in Audio Effects below 

Logic Pro 

Watch the Logic Pro Setup Tutorial on YouTube 

1. The AI InstrumentTM installs as an AU plugin 

2. Open Logic Pro > Settings > Plug-In Manager 

3. Ensure “Use” is enabled for “AI Instrument” and press “Done” 

4. To load the plugin, select the desired track to load the AI InstrumentTM into 

5. Open Audio FX > Audio Units > Staccato > AI Instrument > Stereo 

Reaper 
 

Watch the Reaper Setup Tutorial on YouTube 

1. Ensure the VST3 file is installed within Reaper’s VST plug-in path, then go to  Options > 
Preferences > Plug-ins > VST > VST plug-in paths > Re-scan 

2. Select the desired track to load the AI InstrumentTM into and select FX 

3. Open Developers > Staccato > AI Instrument 

 

https://www.youtube.com/shorts/hVdNdN1_XXM
https://www.youtube.com/shorts/qcRrcrkzFWE
https://www.youtube.com/shorts/-IXxovKuS-g


 

 

Cubase 

Watch the Cubase Setup Tutorial on YouTube 

1. Open Studio > VST Plug-In Manager > Rescan. Make sure the folder containing the .vst3 file 
is listed in “VST Plug-In Path Settings” 

2. Select the desired track to load the AI InstrumentTM into 

3. Open Inserts > Staccato > Other > AI Instrument 

FL Studio 

1. Open Options > Manage plugins > Find installed plugins. Make sure the folder containing 
the .vst3 file is listed in “Plugin search paths” 

2. Star (or “F”) the AI InstrumentTM and open the Mixer 

3. Select the desired insert to load the AI InstrumentTM into 

4. Open Slot > FX > AI Instrument 

Studio One 

1. Open Studio One > Options (Preferences on macOS) 

2. Go to Locations > VST Plug-Ins 

3. Enable “Use VST3 Plug-In System Folders” 

4. Click “Scan” (or restart Studio One to rescan) 

5. Close Options, open the Browser (F5) 

6. Go to Instruments > VST3 (or Effects > VST3) 

7. Navigate to Staccato > AI Instrument™ 

8. Drag the plugin onto a MIDI track (instrument) or into Audio Inserts (effect) 

Pro Tools 

● The AI InstrumentTM is not currently available in AAX format for Pro Tools 

● Use the standalone version 

3.4 Uninstallation 
Windows: Run “uninstall.exe,” which is in the folder C:\Program Files\Staccato 

Mac: Drag the “Staccato AI Instrument” application from your Application folder to your trash 

 

https://www.youtube.com/shorts/enfqLj-NX_w


 

 

4. Getting Started 
4.1 Using Virtual Instruments with the AI InstrumentTM 
 

Watch the Connecting Analog/Digital Instruments tutorial on YouTube 

The AI InstrumentTM is designed to fit seamlessly into your workflow, allowing you to hear your 
music exactly how you envision it: by routing its output to your preferred virtual instruments. 

The channels in the generated tracks won’t automatically match your DAW’s instrument 
tracks, which can often default to channel 1. The AI Instrument™ assigns channels 
incrementally, beginning with 1, except for drum tracks, which are automatically assigned 
to channel 10. Consult your DAW’s user manual for more information on setting channels 
per track. 

 

On Mac: 

1. Go to Application > Audio MIDI Setup 

 

2. In the menu bar, select Window > Show MIDI Studio 

 
3. Double-click IAC icon, then select Devices is Online 

 

https://www.youtube.com/watch?v=a3WcesTD_fw


 

 

4. Open the Output menu by clicking the gear in the top right corner of the AI InstrumentTM. 

5. Enable IAC Driver (click Status on): 

 
 

6. Select “IAC Driver” in your DAW or virtual instrument as the MIDI input 

 
7. In the AI InstrumentTM, press the play button on your generated MIDI to hear it through your 

virtual instrument 

 
On Windows: 

1. Install loopMIDI (Get it here) 

2. Run loopMIDI and create a new port with “Add Port” 

https://www.tobias-erichsen.de/software/loopmidi.html


 

 

 
3. Open the Output menu by clicking the gear in the top right corner of the AI InstrumentTM 

4. Enable loopMIDI Port (click Status on): 

 
5. Select “loopMIDI Port” in your DAW or virtual instrument as the MIDI input 

 
6. In the AI InstrumentTM, press the play button on your generated MIDI to hear it through your 

virtual instrument 



 

 

           

5. Features Overview 
5.1 Create 
Watch the Create Tutorial on YouTube 

Turn any text prompt into unique MIDI stems, sections, melodies, beats, chord progressions, and 
more.  

 

https://youtu.be/L9q0xqQnT6M?si=xvRyX3fBp62dPRB7&t=4


 

 

1. Type a phrase like “Create a sad piano melody in B minor” or a longer prompt like “Make a 
dark cinematic string section building tension, inspired by film composers like Hans 
Zimmer or Trent Reznor” 

2. The AI Instrument™ will create multiple generations for you to choose from 

3. See Sections 6.1 and 6.2 for prompting tips and suggestions 

 

Example Use Cases: 

● Perfect for starting a new track when you’re facing writer’s block or have a rough idea but 
need help getting started 

● Useful for quickly generating MIDI ideas in specific genres or styles 

● Generate ideas for styles you may be less familiar with – extend your musical vocabulary 

 

 

 

Rewrites & Accompaniments 
Watch the Rewrite/Accompany Tutorial on YouTube 

Use text prompts to request changes or accompaniments to any MIDI file. 

https://www.youtube.com/watch?v=5Oqc5kJirk4


 

 

 
1. Start creating modifications or accompaniments in one of three ways: 

1.1. Click a place card of a MIDI file you’ve generated 
1.2. Click one of the tracks within a generated place card 
1.3. Upload your own MIDI file by clicking “Upload +” below the chat box 

 

2. When a MIDI file is ready to be rewritten, it will appear in the bottom left corner of the chat box: 

 

 

3. Ask for any changes or accompaniments: “Make it more syncopated” or “Turn this piano into a 
guitar solo” or “Create drums that match the groove and energy of this melody”. 

4. Create works like a chat, similar to ChatGPT. After it generates a MIDI file from your initial text 
prompt, you can keep giving it instructions to further refine the result. 

Example Use Cases: 

● Helpful for creating bridges or transitions based on existing MIDI tracks 

● Ideal for stylistic transformations (e.g., changing genre or instrumentation) 

● Great for refining parts without manually editing notes 



 

 

5.2 Extend 
Watch the Extend Tutorial on YouTube 

Continue any MIDI song or stem. The AI InstrumentTM extensions stay true to the original, helping 
you explore new creative directions. 

 

1. Upload a MIDI file by dragging and dropping it into the plugin or using the “Upload+” button. 
Extend the generations made in Create by clicking the "Extend >" button, or click the ">" arrow 
to extend individual tracks.  

2. The AI InstrumentTM will generate stylistic and creative continuations to your music 

3. See Section 6.3 for more information on fine-tuning your MIDI extension 

Example Use Cases: 

● Find new ways forward when you’re stuck 

Speeds up the workflow for producers and composers creating longer and more complex 
arrangements. 

 

https://youtu.be/L9q0xqQnT6M?si=mP10EdWaoCy48Jru&t=84


 

 

5.3 History 
History is a feature of the Staccato AI Instrument™ that contains all previous conversations and 
files created by the user. It works in the same way as ChatGPT’s history, allowing you to return to 
even your very first chat, review past conversations, and re-download MIDI files at any time. 

 
The History panel automatically appears on the left and can be hidden by pressing the button 
shown below. 

 

You can also rename any chat to help keep things organized. To do this, move your cursor over the 
chat to highlight it. Click the three dots that appear, then select Rename. Refer to the image 
below. 

 
 



 

 

Example Use Cases: 

● Helpful for returning to previously created or extended MIDI files 

● Keeps all chats, making it easy to revisit sound design tips and discussions 

● Extremely useful when working across two machines—it automatically functions as a 
cloud, allowing you to download MIDI files or transfer them easily through chat 

 

5.4 Listen 
The Listen feature lets you record directly into the AI Instrument plugin. You can do this in one of 
two ways: 

1) By playing your MIDI instrument in real time inside the plugin, or 
2) By recording what’s in your DAW 

 

Play Instruments in the Plugin 
Before using the Listen feature, verify that your MIDI instrument is properly connected to the AI 
Instrument. Refer to the ‘Getting Started’ section of this manual, above. 

To begin, press the Listen button under the text input box: 

 

A new window will appear, as shown in the screenshot below.  



 

 

 

Press LISTEN and start playing your instrument. 

After you’re finished playing, press Stop and the recording will be automatically uploaded to the 
chat window (see image below). Then tell the AI Instrument what to do with the material (rewrite, 
make an accompaniment, etc.), just as you would when adding a MIDI file. 

 

Note: You can also use the VST plugin on a MIDI track if your keyboard is already connected 
to your DAW. 
 



 

 

Record What’s In Your DAW 

In addition, the Listen feature can record MIDI from your DAW and, based on that input, rewrite, 
accompany, or extend it.  

The easiest method is to load the VST plugin on your MIDI track, press Listen in the plugin, and 
then press play in your DAW. The plugin will automatically detect your DAW as the MIDI input. 
Now you can use it the same way you would when playing a MIDI instrument: open the Listen 
feature and enable Listen, and it will monitor your DAW.  

We strongly recommend using the Listen feature this way, as it will always listen to the same 
channel, even while you are performing inside your DAW. 

To use this feature in the standalone plugin, open your DAW and enable IAC Driver Bus (on 
macOS) or LoopMIDI (on Windows) as the MIDI output. Refer to the ‘Getting Started’ section of 
this manual for further instructions. You can then use it as a send or as the direct MIDI output of 
your MIDI track. The exact steps will vary by DAW.  

Here is a screenshot showing how it looks in Reaper. 

 

 

 

Example Use Cases: 

● Ideal for skilled performers who are comfortable recording directly in the plugin 
 

● Useful as a quick idea sketcher: play a melody and ask the plugin to add harmony or a 
countermelody 
 

● Can also be used as a mistake fixer or for chord progression improvement suggestions, 
without needing to record MIDI in your DAW and then drag it into the plugin 



 

 

6. Prompting 
6.1 General Tips 

● Check out our 5 Tips to Create Your Best Music with the AI Instrument™ on YouTube. 

● With Create, you can be as vague or as specific as you like, from a broad mood or genre, 
right down to instrumentation, note range, and rhythmic feel. 

● The more specific your prompt, the more tailored the result will be. 

The AI Instrument™ is designed to generate building blocks for your songs like 
stems, sections, and loops. Please note that more complex requests may take 
longer to generate. We encourage you to experiment with different prompts. See 
Sections 6.2 and 6.4 of this guide for a great starting point!  

● If the output doesn’t match what you had in mind, you can always pass the generated MIDI 
back into Create by clicking the track(s) to continue to make precise adjustments. Or you 
can pass the generated MIDI into Extend via the extend button under the generation to 
increase its length. 

● Avoid abbreviations in text prompts (e.g., use “B Major” instead of “B Maj” or “Bm”). 

● Please note that Staccato generates MIDI, not audio. As a result, prompts related to sound 
design (e.g., attack, slides) may not directly reflect in the MIDI output. However, including 
sound design details in your prompts can help Staccato generate MIDI that pairs well with 
specific sounds (e.g., generating longer notes for instruments with slow attack). In a future 
update, the AI Instrument™ will include personalized sound design suggestions alongside 
the MIDI to help guide your production. 

 

6.2 Create 
Prompt Examples 

● "Make a hip hop hi-hat pattern with triplets, inspired by Metro Boomin" 

● "Create drums with LABS Drums that match the groove and energy of this melody" 

● "Melancholy piano melody in B minor"  

● “Make a bridge section based on the MIDI file I supplied with a big build-up section” 

● "Make it sound more like house" 

● "Driving rock drum beat with fills for EZDrummer 2 Modern kit" 

● “Put the tracks in this MIDI file in this order: drums, bass, guitar” 

● "Funky slap bass groove" 

https://www.youtube.com/watch?v=NfvoLx6FL78


 

 

● "Add syncopation to the rhythm" 

● "Jazz trio groove in 3/4" 

● “Make this Waves Piano & Keys melody sound more human by loosening the timing and 
changing up the velocities” 

● "Minimal techno kick and bass combo, using the Battery 4 Dance One Kit" 

● “Make a dark, fast-paced bassline for Ample Bass P II Lite”  

● "A dark cinematic string section building tension, inspired by film composers like Hans 
Zimmer or Trent Reznor" 

● "Add triplets to every bar to accompany the melody" 

● “Make a dreamy loop with four flowing chords and a simple, catchy melody. Stay mostly in 
a major tonality but add occasional color tones or modal shifts.” 

● "Simplify the chord progression" 

● "Pop-punk drum beat in the style of Blink-182, fast-paced with punchy snare hits and lots 
of energy"   

● "Make the drums tighter and more fitting for electronic music" 

● “Write a slow ballad with extended chords on Addictive Keys Model One Stage Piano. Use a 
walking bass and gentle drum patterns to support the chords.” 

● "Add variation to the hi-hats" 

● “Create a chaotic, exciting drop, with an off-kilter lead melody using a Vital Sawtooth 
synth” 

● "Add harmonies to this melody" 

● "Create a groove with syncopated 16th-note rhythms and tight chord stabs. Use smooth 
voice leading and rhythmic variation to keep it interesting.” 

● "Add a bassline that follows the chord progression but uses passing notes and rhythmic 
variation” 

● “Create an uplifting chiptune melody and bass combo, reminiscent of 8-bit console video 
game music” 

● "Add a lead melody that fits with the existing rhythm section" 

● “Make a pleasant, bouncy guitar solo, inspired by Brian May from Queen” 

● “Make an indie pop verse, with soft acoustic guitar strums beneath a main piano melody” 

6.3 Extend 
● Extend includes two sliders that let you control how your music continues: 

o Creativity: The higher the value, the more unexpected the output 



 

 

o Length: Set the output length. Complex or layered music will shorten length.  

● If Extend’s results feel too repetitive, try increasing the Creativity slider 

Note: The Length slider isn’t tied to a specific number of bars. The more complex 
your music, the higher you’ll need to set the length to generate a meaningful 
continuation. 

 

 
 

7. Frequently Asked Questions 
 

Is the MIDI I get unique to me? 

Yes. Each MIDI file is generated from scratch using your prompt, so your output is unique. 

Very simple requests (e.g., generic four-chord loops) can land on similar material, but your 
instrument choices and sound-design decisions still make each track yours. 

 

Will I own the MIDI that I generate with the AI InstrumentTM? 

Absolutely, it's yours! 

 

Is the generated MIDI royalty-free? 

Everything you generate is royalty-free and yours to use commercially or personally. Our models 
are trained only on data that respects artists' copyrights, and guardrails prevent outputs that are 
too close to existing works. 

 

How do I use my generated MIDI in my DAW? 

MIDI files can be simply dragged-and-dropped from a placecard or track title: Check out our 
tutorial on exporting MIDI from the AI Instrument™ plugin on YouTube. 

 

Can I reference artists in my prompts? 

You can indeed reference artists in your prompts. The AI Instrument™ applies the methods and 
styles of artists without recreating or copying the existing work of others. 

 

https://www.youtube.com/watch?v=wkd5um2LAIk
https://www.youtube.com/watch?v=wkd5um2LAIk
https://www.youtube.com/watch?v=wkd5um2LAIk
https://www.youtube.com/watch?v=wkd5um2LAIk


 

 

Is the AI InstrumentTM trained on other artists' work? 

No. Our models are trained only on data that respects artists' copyrights, and we’ve integrated 
guardrails to prevent outputs that are too close to existing works. The AI Instrument™ learns the 
underlying principles of artists’ styles without directly copying, allowing it to collaborate like a real 
co-writer. 

If you’re still curious, read about our commitment to ethical AI on our About Us page. 

 

Can I buy the AI InstrumentTM for a one-time fee or is it subscription-only? 

It's subscription-only. A flat monthly rate lets you generate, iterate, and refine ideas without 
worrying about prompt credits. 

This model also allows us to support our developers’ ongoing work, ensuring continuous new 
features and updates to the AI InstrumentTM. 

 

Am I limited in the number of prompts I can use? Do I need to buy prompt credits? 

No credits are required. You get unlimited generations with your subscription. 

 
Can I request multiple instruments in one prompt? 

Yes, the AI InstrumentTM supports multi-instrument, multi-track generation. 

 

Can the AI InstrumentTM generate full songs? 

The AI InstrumentTM is designed to help you create musical ideas like stems, melodies, bridges, 
and loops, rather than full songs. You drive the overall arrangement; the more detail you add to a 
prompt, the more complete the result. 

For guidance on writing effective prompts, see Section 6 above. 

 

Does the AI Instrument edit what’s in my DAW? 

No, it is separate from your DAW. You simply drag and drop MIDI between the AI InstrumentTM 
and your DAW. 
 
 
Do I need an internet connection? 

Yes, prompts are processed in the cloud. 

 

https://staccato.ai/about-us


 

 

Does the AI InstrumentTM output audio? 

The AI InstrumentTM generates MIDI, not audio, which you can route to any virtual instrument or 
sampler. 

 

Does the AI InstrumentTM learn from my input or improve over time? 

The current model does not adapt to individual users. The AI Instrument™ is trained to respond 
accurately to detailed, musical prompts. 

 

Which languages does the AI InstrumentTM support? 

You can type prompts in any language! The plugin interface is currently in English, and we’re 
actively working on translating them to additional languages. 

 

Which DAWs and notation software does the AI InstrumentTM support? 

The AI Instrument™ works with any DAW or notation software that supports VST3 or AU. There's 
also a standalone version for drag-and-drop workflows (compatible with Ableton, Logic, FL 
Studio, Pro Tools, Cubase, Reaper, Dorico, MuseScore, and more). 

You can also route MIDI internally using IAC on Mac or third-party tools like LoopMIDI on 
Windows. 

Note: Pro Tools is not supported by Staccato AI InstrumentTM 

What are the system requirements?  

Refer to Section 2 on “System Requirements” for this information. 

 

 

8. Troubleshooting 
Plugin not showing up in DAW: Make sure the plugin path is correctly added in your DAW 
settings. Refer to sections 3.3 and 3.4 for step-by-step instructions to find your plugin directory 
and load the VST into your specific DAW.  

No sound: Ensure the AI InstrumentTM is on a MIDI track routed to an instrument. 

Error message when using .VST3 version: "Something went wrong. Please check connection 
and try again": Check that your device has a stable internet connection; otherwise, the AI 
Instrument™ will time out and display this error message. Make sure your DAW is not blocking 
outgoing connections for your firewall, as this interrupts the plugin from working properly. If the 
error persists, try adding your VST3 or DAW directory to your firewall's exclusion list. 



 

 

 

9. Contact & Support 
● Customer support: support@staccato.ai 

● Feedback: contact@staccato.ai 

● Discord: Join our user community for support, tips, and feedback. 

https://discord.gg/k25R9Kpwx6

